java中一个数的n次方应该怎么写?
在恭城等地区,都构建了全面的区域性战略布局,加强发展的系统性、市场前瞻性、产品创新能力,以专注、极致的服务理念,为客户提供做网站、成都做网站 网站设计制作按需定制开发,公司网站建设,企业网站建设,高端网站设计,成都全网营销推广,成都外贸网站建设公司,恭城网站建设费用合理。
public class Test {
public static void main(String[] args){
double m = 2;
double n = 3;
使用API,Math.pow(double m,double n) -- 'm' 的 'n' 次方
System.out.println("使用API:" + Math.pow(m, n));
通过两种回圈实现的 'm' 的 'n' 次方
System.out.println("使用while实现:" + MToThePowerOfNByWhile(m,n));
System.out.println("使用for实现:" + MToThePowerOfNByFor(m,n));
}
public static double MToThePowerOfNByWhile(double m,double n)
{
double result = 1;
while(n 0)
{
result *= m;
n--;
}
return result;
}
public static double MToThePowerOfNByFor(double m,double n)
{
double result = 1;
for(int i = 0;in;i++)
{
result *= m;
}
return result;
}
}
java 中一个数的n次方怎么写– 智联问道
Math.pow(double m, double n)
是求m的n次方的
你也可以用回圈实现^_^
望采纳~
一个数的n次方怎样搜寻怎样开一个数的n次方
用Excel表格 在空格里输入 =a^n。
3的2次方:就是3x3=9 3的3次方:就是3x3x3=27 几次方,就乘几个相同的数
怎么求一个数的N次方和另外一个数的N次方的差?
2^17-2^13
=2^13×2^4-2^13(把2^17拆成2^13×2^4格式)
=2^13(2^4-1)
你这题出的有点难。考试卷上应该很少能出现这种题。
这样讲明白吗?如果不明白给我空间发信息。我大二,经常线上。或者在百度hi加我为好友。随时解答
一个数的n次方怎么打?
你好:
a的b次方,在电脑用a^b表示
祝愉快!
一个数的N次方怎么算
约等于0,这个需要一个判断标准.
比如要求前6位小数都是0的时候可以看做约等于0,那么就是4100*0.06^n0.000001
0.06^n0.000001/4100
0.06^n2.44*10^(-10)
由于0.061,log0.06x是减函式.
所以由0.06^n2.44*10^(-10),
可知nlog0.06(2.44*10^(-10))
则n7.86,则N=8.
计算可知,4100*6%^8=0.00000068864256,小数点后有6个0,可以约等于0.
其他的演算法都是一样的,先找到到底多少位是0就可以约等于0,然后一步一步计算
一个数的0.5次方应该怎么算?譬如:2
一个数的0.5次方就是2分之1次方,也就是开2次根号
2的0.5次方=√2
一个数的的小数次方应该怎么算
a^(1/n)就是对a开n次根号
而如果不能化为1/n次方的话
就先化为a^(m/n) 次方
得到结果为(a^m)^(1/n)
即先进行m次方,再开n次方
一个数的的小数次方应该怎么算呢?
这么举个例子吧,一个数的0.5次方就是开2次根号
计算2的N次方
时间限制: 1000ms内存限制: 65536kB
描述
任意给定一个正整数N(N=100),计算2的N次方的值。
输入
输入只有一个正整数N。
输出
输出2的N次方的值。
样例输入
5
样例输出
32
参考代码
[java] view plain copy print?
import java.util.*;
public class Main {
public final static int SIZE = 30;
public static void main(String[] args) throws Exception {
Scanner cin = new Scanner(System.in);
int n = cin.nextInt();
int res[] = new int[SIZE + 1];
int i;
for(i = 0;i SIZE;++ i){
res[i] = 0;
}
res[0] = 1;
while(n 0){
for(i = 0;i SIZE;++ i){
res[i] *= 2;
}
for(i = 0;i SIZE;++ i){
if(res[i] 9){
res[i + 1] += res[i] / 10;
res[i] %= 10;
}
}
n --;
}
boolean bl = false;
StringBuffer bf = new StringBuffer();
for(i = SIZE;i = 0;-- i){
if(res[i] != 0 || bl){
bf.append(res[i]);
bl = true;
}
}
System.out.println(bf);
}
}
根据高位低位改进的代码:
[java] view plain copy print?
/*
* Title :power 2
* From :
* Time :2011-10-11 21:10PM
* Author :Eric Zhou,binfeihan
* Email :binfeihan@126.com
*/
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
public static void main(String[] args) throws IOException{
BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
int n = Integer.parseInt(cin.readLine().trim());
System.out.println(my_power_2(n));
//System.out.println(Long.MAX_VALUE);
//System.out.println(Long.MIN_VALUE);
}
public static StringBuffer my_power_2(int N){
StringBuffer v = new StringBuffer("");
long num[] = new long[2];
num[1] = 1;
if(N 62){
num[0] = 1;
num[0] = num[0](N - 62);
num[1] = num[1]62;
String s = String.valueOf(num[1]);
int size = 30,i = 0,j = 0;
long n[] = new long[size + 1];
//System.out.println(num[0]+" "+s);
for(i = s.length() - 1;i = 0;-- i){
n[j ++] = (long) (num[0] * (s.charAt(i) - '0'));
//System.out.println(n[j - 1]);
}
for(i = 0;i size;++ i){
while(n[i] 9){
n[i + 1] += n[i] / 10;
n[i] %= 10;
}
}
boolean bl = false;
for(i = size;i = 0;-- i){
if(n[i] != 0 || bl){
v.append(n[i]);
bl = true;
}
}
}else{
num[1] = num[1] N;
v.append(String.valueOf(num[1]));
}
return v;
}
}
不能直接写的
只能 Q*Q*Q(Q的3次方)
或者你自己写个方法
public class MyMath{
public static int Math(int a,int j){
int b=1;
for(int i = 0;i j; i++){
b=b*a;
}
if(a==0j==0) return 1;
else return b;
}
}